Joey Hafner
4e9d6dec6a
- Delete homeManagerConfigurations from flake. - Delete laptop nixosConfiguration. - Delete `home-manager/` and `nixos/` directories. - Switch from one general "vars" attrset for variables to using built-for-purpose attrsets for variables, each declared where it makes most sense (e.g. the "sys" attrset will be used for system-specific attributes). - Create `systems/` directory for root-level system configurations and `modules/` directory for re-usable config files. - Consolidate most app and system configuration into the `desktop-environment.nix` and `terminal-environment.nix` files. - Standardize all `.nix` files to nixos config nodes, as opposed to home-manager. May reverse this decision. - Use `${sys.username}` for the username of the primary user of the system. - Use `${usr.${sys.username}}` for attributes related to that user (e.g. realname, email).
22 lines
719 B
Nix
22 lines
719 B
Nix
{ sys, pkgs, ... }: {
|
|
services.flatpak = {
|
|
enable = true;
|
|
uninstallUnmanaged = true;
|
|
remotes = [ { name = "flathub"; location = "https://flathub.org/repo/flathub.flatpakrepo"; } ];
|
|
};
|
|
home-manager.users."${sys.username}" = {
|
|
services.flatpak = {
|
|
enable = true;
|
|
uninstallUnmanaged = true;
|
|
remotes = [ { name = "flathub"; location = "https://flathub.org/repo/flathub.flatpakrepo"; } ];
|
|
};
|
|
home.packages = with pkgs; [ flatpak ];
|
|
};
|
|
}
|
|
|
|
# To use:
|
|
# For system packages:
|
|
# services.flatpak.packages = [ "com.myproject.app/arch/branch" ];
|
|
# For user packages:
|
|
# home-manager.users."${sysVars.username}".services.flatpak.packages = [ "com.myproject.app/arch/branch" ];
|