Jafner.net/dotfiles/modules/hardware/goxlr-mini.nix
Joey Hafner 4e9d6dec6a
Refactor flake:
- Delete homeManagerConfigurations from flake.
- Delete laptop nixosConfiguration.
- Delete `home-manager/` and `nixos/` directories.
- Switch from one general "vars" attrset for variables to using built-for-purpose attrsets for variables, each declared where it makes most sense (e.g. the "sys" attrset will be used for system-specific attributes).
- Create `systems/` directory for root-level system configurations and `modules/` directory for re-usable config files.
- Consolidate most app and system configuration into the `desktop-environment.nix` and `terminal-environment.nix` files.
- Standardize all `.nix` files to nixos config nodes, as opposed to home-manager. May reverse this decision.
- Use `${sys.username}` for the username of the primary user of the system.
- Use `${usr.${sys.username}}` for attributes related to that user (e.g. realname, email).
2025-01-08 12:04:28 -08:00

20 lines
582 B
Nix

{ pkgs, sys, ... }: {
services.goxlr-utility.enable = true;
home-manager.users."${sys.username}" = {
home.packages = with pkgs; [ goxlr-utility ];
systemd.user.services = {
goxlr-utility = {
Unit = {
Description = "Unofficial GoXLR App replacement for Linux, Windows and MacOS";
Documentation = [ "https://github.com/GoXLR-on-Linux/goxlr-utility" ];
};
Service = {
Restart = "always";
RestartSec = 30;
ExecStart = "${pkgs.goxlr-utility}/bin/goxlr-daemon";
};
};
};
};
}